[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Edlug Archive Mar 2004 ]

Re: [edlug] Samba problem



-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Been a while since I use samba but do you not have to add the line browseable 
= yes to the data share for you to be able to browse to it?


On Friday 05 Mar 2004 12:22, David R. Baird wrote:
> Hi,
>
> I'm just starting to play with Samba (2.2.7) but ...
>
> [edit - sorry, this got to be a bit long]
>
> I have 2 PCs, 1 Windows XP, and one RH Linux 7.2. I can ssh and
> http from XP to Linux fine, and from the Linux I can ssh, http,
> email etc. Internet (cable modem) comes in to the XP box, then
> out to a hub which the Linux box is connected to.
>
> On the internal network, the XP box IP is 192.168.0.1, and the
> Linux is 192.168.0.123
>
> Hostnames are set up, with XP = eveshampc.mshome.net, and Linux =
> zerofive.mshome.net
>
> From Linux, I can ping eveshampc successfully.
>
> From XP, I can NOT ping zerofive, but I CAN ping 192.168.0.123
>
> On XP, in network places, I see the Linux box, and it has the
> name I set up in the Samba config, so at some level they are
> talking to each other. However, any attempt to access the machine
> results in a '\\Zerofive is not accessible' error, also saying
> 'The network path was not found'.
>
> Nothing at all appears in the samba logs, nor in the messages
> log.
>
> There is no firewall on the Linux box. XP has a firewall on the
> external interface, but not the internal one. Also running
> ZoneAlarm on the XP, but with the Linux box's IP in the trusted
> zone and firewall off for trusted.
>
> I have created a user on Linux with the same name and password as
> the XP user, but I don't think authentication is the problem
> because I would expect to see error messages and log entries. I
> suspect it's to do with hostname resolution, since I can't ping
> the Linux box by name, but I have no clue what to do next.
>
> Here is my Samba config:
>
> [global]
>    workgroup = MSHOME
>    server string = Samba Server
>    security = user
>    encrypt passwords = yes
>    local master = yes
>    wins support = yes
>
> [homes]
>    browseable = no
>    writable = yes
>    create mode = 0664
>    directory mode = 0775
>    map archive = no
>
> [data]
>     path = /home/data
>     read only = no
>     map archive = no
>
>
>
> Ah. While writing this, /var/log/samba/log.nmbd has just spat
> out:
>
> [2004/03/05 12:16:31, 0]
> nmbd/nmbd_browsesync.c:find_domain_master_name_query_fail(358)
>   find_domain_master_name_query_fail:
>   Unable to find the Domain Master Browser name MSHOME<1b> for
> the workgroup MSHOME.
>   Unable to sync browse lists in this workgroup.
>
>
> That makes me suspect something needs nudged on the XP box?
>
> Any help very much appreciated.
>
> Cheers,
>
> David.

- -- 
Mark Robert Dickie
deephack@xxx.xxx.xxx -- Home
ICQ#82716937 -- Home
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.2.4 (GNU/Linux)

iD8DBQFAS3axYFdK3x8Jm/QRAsifAKCRQZeQuoGTcuQKs0+v8KWvEAJiSgCfSb+6
JvWrPYSg086spyoLfQ15rcc=
=Hgry
-----END PGP SIGNATURE-----
-
----------------------------------------------------------------------
You can find the EdLUG mailing list FAQ list at:
http://www.edlug.org.uk/list_faq.html



This archive is kept by wibble@morpheux.org.DONTSPAMME
homepage